Too many redirects on Startpage


I have a small problem with the startpage of a website.

Quick summary:
The page was first developed on subdomain
Then it was moved to main domain

I’ve setup 2 things in htaccess after the move:
Redirect from non-www to www
Redirect from http to https

I had issues with Kirby not detecting the “www” in the URLs

I’ve fixed it with adding to /site/config/config.php file this line:

‘url’ => ‘https://www-website-com’,

and this fixed the problem.

Those are all the changes that I do to the default files


Now I have a problem that on the Startpage many tools (for example google search console or redirect-checker "add org to the name to open the page) say that there are too many redirects

redirect-checker says that there are 19 redirects

Few things that are kind of weird:
Subpages are totally fine. no errors
I can open the Startpage also fine


Does anyone have an idea what could be the reason for those errors on the startpage?

(I’ve changed “.” to “-” only to be able to post)

Where are you hosting? Sometimes the hosting service already does the redirect from http to https, then doing it in the .htaccess as well might cause issues.


After your comment I’ve tried to remove the SSL Rule from htacces but it didn’t fix the problem

Could you please post your htaccess?

# Kirby .htaccess

# rewrite rules
<IfModule mod_rewrite.c>

# enable awesome urls. i.e.:
RewriteEngine on

# make sure to set the RewriteBase correctly
# if you are running the site in a subfolder.
# Otherwise links or the entire site will break.
# If your homepage is
# Set the RewriteBase to:
# RewriteBase /mysite

# In some environments it's necessary to
# set the RewriteBase to:

RewriteBase /
 RewriteCond %{HTTP_HOST} !^www\.
 RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L]

RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

# Cachebuster plugin
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.+)\.(\d+)\.(js|css)$ $1.$3 [L]

# block files and folders beginning with a dot, such as .git
# except for the .well-known folder, which is used for Let's Encrypt and security.txt
RewriteRule (^|/)\.(?!well-known\/) index.php [L]

# block all files in the content folder from being accessed directly
RewriteRule ^content/(.*) index.php [L]

# block all files in the site folder from being accessed directly
RewriteRule ^site/(.*) index.php [L]

# block direct access to Kirby and the Panel sources
RewriteRule ^kirby/(.*) index.php [L]

# make site links work
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php [L]


# Enable authentication header
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

# compress text file responses
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE application/json
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript


I’m also wondering if it doesn’t have something to do with “GEO-Redirects” since there are 2 languages? Is there a maybe a easy way to turn it off temporarily?

Fixed the issue.

I’ve set it to false and it fixed the problem