The post address of the Google search results is different from the actual one

Hello, I’d like to inquire.
I asked the same question before, but I haven’t fixed it yet.

There is a gallery website made by Kirby.
If I search Google with the gallery name and artist name, only some posts will be searched.
When I click on this post, url is a little different.

For example,
The actual url is

The url of the posts being searched is

Why does the address(url) change?
I don’t know why.
Is it related to Kirby’s setting?

for context: the other topic

Hello, I read the article you helped me with last time.
Now, the old version of the website is not being searched…
A new website is searched, but the problem is that the detailed address of the searched page is different from the actual published page detail address.
When I search on Google, the following details of the domain will be changed. I don’t know what to consider.

This is still the same issue as @rasteiner wrote about in the other thread.

The correct URL on your new website is That’s the URL that works in the browser.

When you search for thepage-gallery byun chong-gon on Google, the search engine returns a link to the URL …that is apparently an old URL from a previous version of the website – as can be seen in the Internet Archive at where that URL is archived to contain the artist page of your old website.

So your problem is that Google still knows the “old” website and has not learned that your website’s URLs have changed.

As pointed out by @rasteiner, you’d have to do two things:

  1. ask Google to re-index the website – that is done by setting up the Google Search Console (as you apparently have done, since there is a google-site-verification meta field in your HTML); it may take anything from a few days to several weeks until Google actually visits your page and learns about your new URLs

  2. make sure that anybody visiting the old URLs like receives an HTTP 301 “Permanent redirect” error code (rather than an HTTP 404 “Page not found” error, as is the case now). You can do that by installing the suggested plugin and set up a redirect from /artist/biography/47/Chong-Gon-Byun to /artists/byun-chong-gon and doing so ensures two things:

    • it does not matter that people still get the old URL from Google for a while, as their browsers will react to the 301 error and redirect them to the new URL (whereas with the current 404 they simply receive an error and think your website is broken)

    • once the Google robot comes to visit in a few days/weeks, Google will be able to understand that the URL for this artist’s page has permanently changed and it will update its database accordingly; if you keep the 404 as it is now, Google might just assume there is a temporary problem with the page and not actually update the URL in their index. This is the only way to tell Google that the new URL represents the same content as the old URL.


Hello. Thank you very much for your reply.
I tried to install the program 'retour 'you told me, but there was an error message that Kirby’s version was not correct.
I wonder if I should change Kirby’s version or if there are other programs that are similar…

The most recent version of the Retour plugin requires Kirby 3.6.1+ – updating your Kirby version is always a good idea to stay up-to-date, but there might of course be breaking changes between major versions. is the most current Kirby version from three days ago.

If you can’t update to a version that supports Retour at this point, there are some alternative options. The plugin kirby3-redirects seems to work for Kirby 3.5+:

…or you could try this solution, which does not provide a Panel UI as the plugins do, but instead the redirection rules are stored in a JSON file:

You could also deal with the redirects directly in your server configuration (the .htaccess file on Apache, or the.conf files in Nginx).

1 Like