Sudden – the JSON response from the API could not be parsed. Please check your API connection


I was just contacted by a former client that all of a sudden the following error message appears in the panel.

The JSON response from the API could not be parsed. Please check your API connection.

I already checked the forum and the docs, there are a couple of answers and solutions to this error message however none of them address a sudden occurrence of the error message.

My guess is the hosting company updated something which broke the panel and that it’s a server error. Why else would the error message suddenly appear after almost a year without ANY changes to ANY Kirby files whatsoever.

The API request response shows the errors

Failed to load resource: the server responded with a status of 500 (Internal Server Error)


Uncaught SyntaxError: Unexpected token ':' in index.js

Any tips are gladly welcomed!


Which Kirby version is installed on the server? And which PHP version?

I think the problem will be solved however I’m still waiting on the hosting company’s reply on my findings.

phpinfo() shows PHP 7.2 which is weird since Kirby needs 7.4 to install, so they must have rolled the PHP version back from 7.4. Why they’d do that, remains a mystery.

That’s not correct, Kirby versions prior to 3.5 required at least PHP 7.2, from 3.5, PHP 7.3 is required.

1 Like

May I ask which hoster you use? I had the same error yesterday and as quick as it appeared it disappeared again.

It’s a really really small local one, I think it’s just one or two guys.

Ah ok, so it’s probably not PHP related at all. Hm.

I quickly turned on debbuging on the live site to check, it’s throwing the following error.
(On the frontend on first load, after a refresh everything works fine. However on the panel not at all.)

PHP Startup: Unable to load dynamic library 'intl' (tried: /opt/php-7.2.14/lib/php/extensions/no-debug-non-zts-20170718/intl (/opt/php-7.2.14/lib/php/extensions/no-debug-non-zts-20170718/intl: cannot open shared object file: No such file or directory), /opt/php-7.2.14/lib/php/extensions/no-debug-non-zts-20170718/ (/opt/php-7.2.14/lib/php/extensions/no-debug-non-zts-20170718/ cannot open shared object file: No such file or directory))

Unfortunately I can’t really make out what this error message says. Any tips would be appreciated!

After googling, I guess the whole thing is a PHP issue on the hosting company’s side.

Yep, I think so too. Usually, when something doesn’t work any more from one day to the next, and you haven’t made any changes at all to your project, it’s a problem with hosting having made changes and suddenly extensions are missing or whatever.

It’s a problem you sadly have if you don’t have full control over your environment.

1 Like

Sorry for the late reply lol, yeah turns out the hosting company deactivated some PHP classes/libraries when first downgrading then upgrading their PHP. :man_shrugging: