Strange Panel behavior (License and Language Switch)


#1

I registered it on localhost and there was everything fine. But on real server I still get this message. Do I have somehow to unregister the localhost?


#2

Have you registered again on the live server?


#3

Yes… and got a “Thank you for supporting Kriby” but the no license message is still there


#4

… I also see no languages on the settings screen and been unable to switsch languages in the panel


#5

Have you set languages to true in your config.php?

As regards the license, try deleting the .license file in the config folder, then register again


#6

The license issue seams to be solved now. But the language issue is still there. here is the config…

<?php

return [
‘debug’ => false,
‘languages’ => true,
‘language.detect’ => true,
];

I see the langues on the settings screen within the panel and the lang switcher is also there but if I use them nothing happens. And the most strange thing is… I see some pages in german and some in english (within the panel… the website itself works fine)


#7

I think it should be languages.detect (with the s), but that shouldn’t case the issue.

Hm, have you checked your content files? Do all pages have the language extensions?


#8

Yes all files are there… I also replaced them several times. And I noticed that the license issue still there in chrome. But works in FF. And the whole site works on localhost and an other server without any problems.


#9

License: Maybe a browser plugin? Or a caching issue?

Languages: If it works on localhost and on another server, what are the differences between these environment (PHP version, web server, caching etc.) Looks like the site itself is ok then, rather a server issue.


#10

PHP versions are 7.1.6 (on not working server) and 7.3.3 (on working server)
All the required extentions are anabled ( mbstring, curl, ctype, gd)

But there is an additional note on the 7.1.6 Version

with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.1, Copyright © 2002-2018, by ionCube Ltd.
with Zend OPcache v7.1.6, Copyright © 1999-2017, by Zend Technologies

what ever it means


#11

Maybe an Opcache issue? https://getkirby.com/docs/guide/troubleshooting/panel#opcache


#12

oh this looks very promissing but with this entry I get an 500 error


#13

Maybe you can switch the cache off in your hoster’s control panel (cPanel) or whatever they use? If in doubt, contact their support.


#14

I have no access to the server config but contacted the hoster… thank you very much sofar… will post the end of the story here


#15

the hoster told me to add ini_set('opcache.enable', '0'); to the index.php
For me it has no effect but for the client it works. So it’s not 100% clear but it looks like Kirby 3 Panel has problems with OPcache.


#16

In my localhost environment, the Panel works fine with OpCache enabled. It probably depends on the settings. But what do I know…