Plugin ist not loaded on Public Domain

Hello there,

I just finished a website for a customer and uploaded the Files to a public domain.
Opening the website i get the famous error Kirby \ Exception \ NotFoundException (error.template.default.notFound)

The default Template is outsourced to a plugin.

I can access the panel, the pages ares listed there but the panel shows the default Kirby structure and not the structure defined in my plugin.

This leads me to think that the Plugin cant be found on the live Domain. Locally everything works fine. May this be an htaccess issue?


I once had a similar problem and did not pay attention to upper / lower case in the file names.
Locally everything worked, but on the server case sensitivity was important.

Thanks for your advice. I am using my plugin for a lot of projects and never had this issue and every file is lower case. But i guess it may be something with the URL cause i used localhost/kunde/callcenter-fun/ locally and public.

Does the home page actually use the default.php template?

Hi thanks for your reply.
the “default” template is just my fallback / 404-Error Page. I have a “home” template in my plugin. But because the plugin is not loaded, Kirby tries to look for the “default” template.

Have you tried to re-upload all your files? Make sure that all file and folder permissions are correct. The only reason why a plugin wouldn’t be loaded is missing read permissions.

I uploaded the files again already and also provide full permissions for every file and folder. It did not work. I tried it again and than it worked… I guess FileZilla did not uploaded everything perfectly before. Sorry for the alert

1 Like