Page slug not generated correctly

Hi! After I updated to Kirby 3.3.0, I registered a problem with page slugs. My default language is Czech. When I create a new page, the slug drops some letters instead of replacing them.

For example, I expect this:
slug-ok

But what I get is this:
slug-ko

It worked fine in 3.2.5.

Hm, have you tried setting the slug language?

Not sure where the

Str::$language = [];

part from the docs article should be placed in my code. But I tried to set the “slugs” option in config.php and even language specific slug rules, as suggested in the guide. No effect.

1 Like

Ok, I have to look into this.

1 Like

Hm, yes, looks like this is a regression.