Need help verifying my machine has problem

I’m having a strange problem with my machine and i’m having a hard time resolving it. I’m hoping someone might be kind enough to spend 10 minutes to see if they get the same result. Basically when i spin my project up, webpack quits immediately with no errors instead of spinning up browsersync and proxying a local domain. This is a setup ive been using for months and is known to work. Im at a loss why its suddenly stopped.

I made a little project the other day for this blog post and i get the issue with it (it worked fine a few days ago when i wrote the blog post), as well as new projects. i dont know wether this is an issue with my machine or node, or whatever.

To reproduce:

  1. Fetch this repo and throw it on a local server
  2. Setup a local domain name (ie quicktest.dev) and Open up webpack.mix.js and scroll down a little way to line 19 and amend it to match your domain name:
  3. Run yarn install. It should install a few bits, then automatically run ‘yarn start’

The problem i’m getting is that it says webpack is watching files then 2 seconds later says it done and drops out to the command prompt. i know webpack is ok becuase it compiles if run yarn production.

if your terminal ends up looking like this:

$ yarn watch
$ cross-env NODE_ENV=development webpack --watch -d --verbose --progress --hide-modules --config=$npm_package_config_webpack

Webpack is watching the files…

✨  Done in 1.71s.
✨  Done in 2.49s.

Then the issue probably isnt my machine, its a bug with Laraval Mix or something. If it fires up a browser window with Kirby PlainKit in it, and you get browsersync output in the terminal, then my machine has a problem :frowning:

Thanks guys, really appreciate anyone chipping in to help me.

Think i’ve got to the bottom of it. Seems to be an issue with Laraval Mix 2.0. Anyone else seen any weirdness with it?

For my fellow Kirby kin, I’m willing to do whatever necessary - if still this is what you require of me?

Thanks @S1SYPHOS but after 5 hours I got to the bottom of it. It’s a bug in a specific version of the webpack browsersync plugin that doesnt seem to like certain versions of webpack. Since Laraval Mix installs these automatically, you end with a broken setup, as I did, when i flushed out my node_modules.

In case others get the problem…

Glad you could sort it out!