Can't live edit blueprints through browsersync

Hello there,
this is my first post :slight_smile:

I discovered Kirby a while ago and I’ve been diving into it a week ago for a new project. So far, what an amazing project and community! Congratulations.

At the moment I’m trying to set browser-sync with yarn so I can speed up my work and be able to have the site refreshed as I work on it.

So once browser-sync is installed, I run browser-sync start --proxy 'http://localhost:80' --files \"./site/**/*\" \"./src/**/*\" and it looks like it’s working.

(I run kirby on a local docker-container thanks to your amazing guide I found in your cookbooks)

Content page is refreshed when I update its template. All good.

But if I get into the panel and open a content page to edit it, I get the error The operation is insecure displayed and I can’t get to it.

That’d be great if I could display that page, that way I could work on its blueprint and see live my changes.

I guess it’s due to browsersync acting as a proxy :thinking: Is there something I can do in the config of kirby maybe to bypass that protection while I’m on localhost for dev purpose?

Thanks for your help !

No clue at all? :slight_smile:

No idea, but have you tried different browsers? Where does the error appear?

Not at all familiar with docker but with Laravel Valet and Esbuild and browser sync something like this does the trick:

  proxy: 'http://yoursite.test',
  files: [
  notify: true

Im wondering if your being a bit too broad with your --files setting