Navigation links only work upon refresh

Hi, I’m a total novice and am working on a draft of my first Kirby website.

So far everything is fine except my navigation bar links. I built the site on my desktop and it all works fine on Terminal through local host.

However since uploading to cPanel the navigation links do not load upon the first click but do work after hitting refresh. I can’t figure it out!


Hello and welcome to the forum :wave:

Do you mean the blog and shop links? They appear for me without refreshing

1 Like

Hi :wave: thanks for your help.

Yes, those are the two link I am referring to - they work fine in testing, but since uploading the site they do not load until I hit a manual refresh.

I agave tried clearing the cache, and have tried using different browsers and different devices but still have them same problem.

Could it be that I have uploaded php files and not html? Or could it be that I haven’t purchased a ssl and something is blocking the page loading before it is refreshed?

Thanks again for helping!

I also cannot reproduce your issue. When I open the link above, I see the navigation links no problem. Tested with Firefox.

Thanks for taking a look, sorry my initial post may have been misleading - I can see the nav links, but clicking them just leads to a loading page until I manually refresh the page.

OH, altright, but the URLs the links link to make no sense in a Kirby context. Modernism in the UK

How did you generate those URLs?

See: Menus | Kirby CMS

1 Like

Hi there,
I can reproduce your problem (FF 91 & 97 Mac), it seems to be some routing problem or with Ajax-request.

When the link is clicked the request has a .json at the end and get a 404

But when you reload the page, the .json disappears and the request is succesfull

I hope this helps to narrow down the error.

1 Like