Mixed content problems

Sorry if this seems simple, I just need some direction.

So for some reason, all of a sudden pages aren’t loading properly… error is showing assets loading as mixed content.

apparently, there is now an auto ssl on our host… so now it seems like any $page->url() goes to https but all my <?= css(['assets/css/index.css', '@auto']) ?> are being served as http. So CSS and javascript are not loading now.


Try setting the URL in config to your https based domain for a quick fix https://getkirby.com/docs/reference/system/options/url

Yes… I had tried that but was still getting mixed content errors where all items in the assets folder were still trying to load as http

Is that on shared hosting or do you have control over the server configuration?

Yes, this is shared hosting.

Can you disable forced SSL and force it in .htaccess. Or force https in .htaccess additionally?

In this case, try to force http->https in your .htaccess (at the very top after the RewriteBase statement):

RewriteCond %{HTTPS}  !=on 
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]