Kirby

Markdown is not working

Hi,

I switched from kirby 2 to kirby 3 with my page. unfortunately, not all markdowns are working. I see, that lists, code blocks, links work well, but:

Headlines work only if there is a leading line feed (#, ##, ###)
“italic” works not (neither blabla nor blabla; which one is right?)
“bold” works not (blabla)

are those findings known bugs or am I doing something wrong?

I’m not aware of any markdown bugs.

Have you tested with the Starterkit in your environment?

hm … I see it also working in my initial post - seems that your forum is also working with markdown :slight_smile:
How ever - it works not with my installation, which is migrated from kirby 2. I updatet to the latest kirby version, needed hours to update bluebrints and some templates. Didn’t change contect. But I am wondering, what else can be reason for markup not to work. Maybe the config.php? I am still using the old one (k2)

You can’t use the old config file. The syntax has completely changed.

cleaned the config.php. Didn’t help …

Could you test if it works in a fresh Starterkit?

Do your server run mb_string ?

fresh starter kit incl. example content is working well for what ever reason. And when I install my old content- and site-directories, it stops working. strange.

I don’t know. If I search in the server settings, i cannot find such a parameter. But as mentioned one post above, it works with the fresh starter kit install. so to me it seems, that the server settings should be sufficient.

The Panel checks if the mb_string extension is installed on installation. A missing extension would end up in messed up content, anyway, not in markdown only partly working.

If it works in a fresh Starterkit but not in your installation, then it’s probably not the server’s fault.

Do you use any plugins? What Kirby version?

Are you using any custom methods to render your markdown fields?

Deleted all plugins => didnt help.
Kirby version 3.1.4 (I deleted kirby folder and copied it again to be sure not to have some left over files)
Methods to render markdown fields: kirbytext()

Now what I found out might be interesting:

When I write it like this, it doesn’t work: The word “Technologie” isn’t written in italics.

(image: logo-v2b.gif class: articleimg_l link: http://hundhome.de)
Im Rahmen meines eHome-Selbstversuchs verwende ich *Technologie* als festen Bestandteil meines alltäglichen Lebens.

When I write it like this, it works: The difference is additional CR behind the (image)-block

(image: logo-v2b.gif class: articleimg_l link: http://hundhome.de)

Im Rahmen meines eHome-Selbstversuchs verwende ich *Technologie* als festen Bestandteil meines alltäglichen Lebens.

I have observed in general, that there must be an additional CR between markdown symbols and kirbytext-sections. Is this a bug or does it mean anything?

I don’t know, I always include a blank line by habit, makes text more readable, but if it worked in K2 but not in K3, then that’s at least a pain in the neck if you have to update all your files.

You can probably use a filter that inserts a new line after an image tag.