Links dont work - not found

I am new here.

I have installed kirby on a GCP server following this guide:

apache seems to work. php is 7.3.

when i go to the Kirby page:


I get the Maegazine page but with no images. When I go to the links I get 404 errors.

I have tried messing with .htaccess and apache2.conf, with no success.

Any help would be great.

Look for

Why do you use PHP 7.3?

Thanks for the response.

I have added junk to the .htaccess file and i do get the internal server error. So that seems to be working ok.

php 7.3 was what it got upgraded to when I ran apt upgrade.

Is it the .htaccess file from Kirby in the /kirby directory ?

the 404 error i get is:

Not Found

The requested URL /index.php was not found on this server.

Apache/2.4.29 (Ubuntu) Server at Port 80

I believe so, it installed in the kirby folder when I installed kirby from git

Please check the other points in my linked page!

Thank you for your help. I guess the rewrite base needed to point to /kirby. It works now!

1 Like

I’ve the same issue on Arch with PHP 7.3. I know my local httpd/apache server works as it is also working with other CMS like WordPress or Contao. I also do get 404 errors on all subpages. I’ve installed kirby in /srv/http/kirby/ and access it via http://localhost/kirby.

@glumanda You probably have to set the RewriteBase in your .htaccess to the kirby subfolder.

RewriteBase /kirby

I already tried, no success :frowning: Still can’t access any subpages. The only way I get to work it is to use the php builtin server.

Have you made sure rewriting is enabled? And are .htaccess overwrites allowed at all? Try putting some nonsense into the .htaccess. You should then get a 500 error.