Kirby v1 - redirecting to homepage all the time

Hi all,

I’ve a website running on Kirby v1 that’s - after switching from hosting provider (with new php version and https://) - is redirecting since a couple days to the homepage all the time:, the 3 different language version of the homepage are working, all subpages aren’t and are redirecting to the homepage. Also /panel is working, but all other pages there are redirecting too to the homepage.

In the Troubleshoot I see:
Can’t detect url rewriting. You are probably not running Kirby on Apache. You might need to setup your own rewrite rules depending on your server setup.
Your PHP Version
Your Server Software
Apache/2.4.25 (Debian)

In the headers of the request I see:

Request URL:
Request Method: GET
Status Code: 302 
Remote Address:
Referrer Policy: no-referrer-when-downgrade
content-length: 0
content-type: text/html; charset=UTF-8
date: Wed, 06 May 2020 18:58:20 GMT
referrer-policy: no-referrer-when-downgrade
server: nginx
status: 302
strict-transport-security: max-age=31536000; includeSubDomains; preload
x-content-type-options: nosniff
x-frame-options: SAMEORIGIN
x-powered-by: PHP/7.2.17
x-xss-protection: 1; mode=block
:method: GET
:path: /nl/wat/gelaat
:scheme: https
accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
accept-encoding: gzip, deflate, br
accept-language: nl-NL,nl;q=0.9,en-US;q=0.8,en;q=0.7
cookie: _ga=GA1.2.2014135246.1586194625; _gid=GA1.2.1413941259.1588791211
sec-fetch-dest: document
sec-fetch-mode: navigate
sec-fetch-site: same-origin
sec-fetch-user: ?1
upgrade-insecure-requests: 1
user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.129 Safari/537.36

Any ideas?
Thanks in advance!

Hm, you say the server is an Apache, in the headers it says nginx, which might be a fake, of course.

But have you actually changed servers? .htaccess only makes sense on Apache, on nginx you have to use your own custom configuration and make sure that rewriting is enabled and working.