Kirby Session Cookie

Hi everyone!

Do you have an idea why there’s Kirby Session cookie here?
There’s no multilingual functionality enabled.

Is there a way to disable it?

Thank you!

  • Do you check for $site->user() in the config or templates/snippets?
  • Are you using an older Kirby version?
  • Are you using the uniform plugin?

@mzur: Any way to prevent the session cookie when using Uniform?

Not at the moment, I’m afraid. The session is required by the Post-Redirect-Get pattern that kirby-form uses. I can look into it when I have some time but I think removing the requirement for a session would need fundamental changes to kirby-form and Uniform.

@mzur Thanks for your quick replay. Yeah, I was afraid that is the case from looking at the source code.

As noted in the newly pinned post, the csrf helper requires a session, too. So there is absolutely no way around having a session (cookie) with kirby-form or Uniform.

Thank you for your replies!

Actually, I am not using Uniform in this project. Also, $site->user() is not being used, and the Kirby version is the latest one :frowning:

The Kirby Comments plugin is being used, but when I stop it, there’s still kirby_session cookie.

Have you made sure that no plugin uses any calls to $site->user()? Kirby definitely doesn’t set any cookies unless the language detection is enabled (and in the Panel, of course). I was able to remove cookies from all my sites…

Found it! It was the Detect plugin that starts a session. Thanks a lot, @texnixe! :blush:

1 Like