Kirby panel slow adding new pages, PHP 5.4.29

When I add a new file via the panel, the site runs fine. However, when I try to add a new page, the progress bar slowly creeps across the top of the browser. I have to re-load the page to interrupt whatever it is trying to do, and then the new page shows up. Have you seen this before?

On my dev server running PHP 5.4.13, it works fine. Don’t know if that’s the issue or not.

Also, my staging server is running version 5.6.10, and it also creates new pages effortlessly.

Are Kirby and the panel on the same version?

Also, have you tried uploading the site to your production server again? Maybe a file is missing or corrupt.

Sorry, where can I check those versions?

I think I found it. Looks like I’m running Kirby version 2.2.3 and panel version 2.2.0. But those both seem like the most recent versions?

Thanks for the tip lukas. I’ll wipe the server again at night when we have less traffic. I’m using git, so you’d think everything would be there…

In the Panel on the Site options page.

Panel, Toolkit and Kirby must be on the same version, i.e. 2.2.3

OK, checking in the Panel I see 2.2.3 for everything:

That’s ok then, so it seems rather that something got corrupted on the way, seems to happen once in a while.

Hm, which typeface is that? Seems like the corruption starts there. :wink:

Ha. It’s Sentinel from Hoefler & Co. fonts. Wanted to customize it a bit for the client. But it works on my staging server just fine.

1 Like

I don’t think the font is the problem here, actually.

Makes sense. My first thought was “wait a minute, this is not how Kirby looks by default” and my second one was “maybe he customized it”. This is most definitely not the issue. :slight_smile:

I finally wiped the site and did a fresh pull from the my project in github, and am still seeing that unresponsive behavior when I try to create a new page. Do you think I should try a different version of PHP?

It’s worth a try after all …

So it ended up being an issue with the autopublish plugin I was using. I ended up removing the plugin for this project, but this has been fixed in autopublish. Thanks for your troubleshooting help!

1 Like