Kirby 3.9.8 and inconsistent query filtering?

Okay, either it’s a but or a feature I don’t get:
With Tags query, I can’t find a consistent way to filer queries, either it’s a feature I don’t understand or it’s a bug, I’m running Kirby 3.9.8 with PHP 8.1.26
When I type “centre”, I have several occurences available but I can’t see “centre d’enseignement”
image

But when I type “centre d”, “centre d’enseignement” appears?
image

But when I type “centre d’” with the apostrophe, nothing appears??!?
image

Could you please post your blueprint (at least the field part) for easy copy/paste testing? Thanks!

Sure:

   tags:
        label: mots-clef
        translate: false
        required: true
        min: 1
        max: 7
        type: tags
        options: query
        query: page.parent.childrenAndDrafts.pluck("tags", ",", true)

Haha, thanks, yes, I thought there would be a list of these options for testing…

What do you mean by “a list of these options”?

here are some assigned tags:

cabane
café
cafés
cafétéria
camping
campus
canal
cantine
capitainerie
caravane
caravanes
carnaval
carrefour
carrière
cascade
cascades
caserne
casino
cathédrale
cellule
cellules
centrale hydro-Ă©lectrique
centrale nucléaire
centre administratif
centre aéré
centre archéologique
centre commercial
centre culturel
centre d’accueil
centre d’affaires
centre d’art
centre d’échange
centre d’enseignement
centre d’expositions
centre d’hydrothérapie
centre d’information
centre de calcul
centre de conférence
centre de congrès
centre de formation
centre de loisirs
centre de production
centre de recherche
centre de repos
centre de réunion
centre de santé
centre de télécommunication
centre de vacances
centre des arts de la scène
centre des congrès
centre gouvernemental
centre médical
centre municipal
centre naturiste
centre nautique
centre pour la jeunesse
centre religieux
centre scientifique
centre spirituel
centre sportif
centre thermal
centre urbain
centre ville
cérémonie
chaire
chalet
chalets
champignonnières
chantier
chantier naval
chapelle
charpente
château
château d’eau
châteaux d’eau
chaufferie
cheminée
chevet de l’église
cinéma
circuit
circuit de karting
cirque
cirque d’État
cité
cité hospitalière
cité judiciaire
cité ouvrière
cité universitaire
classe
clinique
clinique universitaire
clocher
cloître
club
club des jeunes
club méditerranée
club nautique
club-house
collège
colombier
colonnade
commerces
communauté
complexe hĂ´telier
complexe spatial
complexe sportif
coopérative
coque
coques
cour
cour intérieure
coursive
coursives
couvent
crèche
crypte

Hello were you able to reproduce this bug?

Oops, sorry, got totally sidetracked and forgot about it but did a test now.

I cannot really reproduce this. Wondering if it has to do with the number of items shown in the list and their order. After all, there are only 10 items max, and since your are not sorting, but showing them in the order they appear in the content, that might be causing this?

But is is possible to change the 10 items max and sorting them? How do I do that?

Sorting: Via a custom page method that returns the sorted array.
Number of items: Can be set via the search option

tags:
  search:
    display: 20

Okok I’ll try and how about these 2 remaining questions?

Isn’t that one question? Yes, I had this problem as well, seems to be an issue how you type the apostrophe.