Thank you and your team for this great improvement “Permissions”. I played around with beta 1 / 2 during the past time and it runs very good.
So the following is not aimed to change the real code but the interface to the permissions.
If I look at Kirby docs: Available permissions, I see some inconstancies in the names of the permissions.
All permissions (without “
panel.access”, where this exception is ok) consist of three words each connected by a dot:
- the first word is allways “
- the second word describes the aim of the special persimission
- the third word describes the kind of the special persimission
But there are three permissions, that follow not the same word building rules of the others:
the first and the third of these three permissions belong to the “Site options”,
the second belongs to the “Users menu”.
So my idea is to change the names of these three permissions, e.g. like:
[Edit: *) = changed because of the following hint from @jbeyerstedt]
May be, if you change the the third word “
read” to “
access”, everywhere where it occurs, this would say more, what the particular permission does.
Thanks for your time.
I know, that this will break the configuration of testers like me. But in a beta version in front of the first running version with permissions this is better than you will do that some versions later.