Https, Mamp, Codekit, Fritzbox - no more local developement of my Kirby Site

  • Browers don’t allow http connections, even when local.

  • Cerificates from Codekit don’t work with MAMP PRO (4).

  • In Codekit the Bonjour Server is suddenly „local.fritz.box:5757“.

  • I don’t know how to get ridd of this FritzBox thing outa Codekit

  • No server adress I try works. Neither Codekits „57572 nor MAMPs „8888 / 8889“.

I don’t know, what to do.

I am ready to ditrch MAMP PRO but didn’t find an alternative. AAMPS doesn’t work on my machine (MacOS High Sierra).

Local by Flywheel is only for WordPress. The say it supports non-WordPress Sites, but I couldn’t import my Kirby Site into that thing.

Help!

I have never experienced this yet.

Have you tried to create a self-signed certificate in Mamp itself?

Fritzbox is a kind router. Are you using a Fritzbox router? Maybe its gone haywire or maybe it has got a virus or something. Try re-setting it or updating it. Sounds to me like your networking has gone strange, rather then fault of MAMP or Codekit.

I can recommend Valet+ for local development, it’s free.

If you are not familiar with working in Terminal and prefer a GUI based tool, this might not be for you.

Have you restarted your computer and fritzbox? Only two days ago, I suddenly couldn’t access my websites via local network IPs anymore and couldn’t figure out why that happened.

Also, instead of Bonjour, try one of the other options in the dropdown. And check out the Codekit troubleshooting docs.

I have almost your exact same setup (Codekit + Mamp Pro (5) + High Sierra) and I have never experienced something like this. It’s probably the FritzBox that is causing the issue IMO.

Thanks everybody.

@jimbobrjames

Yes “Fritz!Box” is a very popular router in Germany. Its good as far as I can tell with a lot of practical features. But it somehow blocked any local access to any php sites.

@texnixe
I switched my Wifi off/on and then this Fitzbox-voodoo was gone.

But at last Apache wouldn’t start. This was because the LocalByFlywheel installation must have done something to the root folder of the site. I tried the normal MAMP App and it did start Apache.

So, I created a new host for the site with a brand new private certificate for it and MAMP would load the site.

Now Codekit would show the site as well, with a now correctly typed server address (hrm-hrm) but unfortunately without any CSS. No idea why not. If I load the site with MAMP CSS works.

PS: Big fan of Codekit, by the way.

Check in dev tools if it is maybe trying to load CSS via HTTP instead of HTTPS. Clear the browser cache. Enforce HTTPS in Kirby config.

c::set('ssl', true);

I tried all of that including c::set('ssl', true); - but had no luck.

All browsers deny access to my site. They don’t trust my own certificate.

At the moment only Safari would allow me to make an exception to the security thing. When I use MAMP and Safari I get the page with css and all assets like imgs.

Safari and Codekit give me the page with no css and no assets like imgs.

This is from Chromes dev tools:

Bildschirmfoto%202

I guess it was me who screwed something up.

I tried another Site, that I did with Craft and it shows up fine with (what seems to me as) the same set-up of Mamp and Codekit.

I should maybe say, that I recently pulled down the assets and content folders from the life site to my local enviroment and I guess that maybe it has to do with that?

I’d set up a fresh Kirby Starterkit and test with that first.

Pulling a project down from remote shouldn’t usually screw anything up unless there’s something wrong in the configuration or .htaccess.

Did you create. your certificate in Mamp or in Codekit?

Try to open the website in Chrome in an incognito window, it should work if you click on the button “open insecure website” or whatever it is called.

Seems that even if you trust the certificate in keychain, Chrome will only open it when using this deviation. The alternative would be to install a let’s encrypt certificate locally.

@texnixe

Since I had no images and css, I thought it would be some CORS issue, but there was only the Kirby htaccess file.

I tried a fresh Kirby starter kit and it worked just fine.

I had a made certificate for the problem-project in MAMP and had also tried to connect MAMP to the CodeKit certificate before, but nothing helped. I had set the CodeKit certificate to „always trust“ in keychain app long ago, but it didn’t do the trick this time.

So I set up a new Mamp server for the problem-project with no certificate and no SSL. And MAMP showed the problem-project just fine. Although the urls in that project are „https“, nothing went wrong.

Then I tried to open it using Codekit, but this time I set the URL to „.test“ not „.dev“. This is a trick from Codekits developer, because with „.dev“ Chrome and Firefox demand https, but not with „.test“. Must try „.oops“ next time, though, cause it suits me better.

Strange thing was, once I used „https“ in the url in Codekit, my FritzBox router would take over the url and change it to its name and my site wouldn’t show. WTF.

Golly golly golly - what a hussle with that security. That browsers wouldn’t allow a user access to his own site especially with Wifi off and on a localhost network.

Anyway - now it works even with images and css!

Thank you so much once again, Texnixe!

Just to clarify - you can’t use “.dev” locally any more. The issue isn’t because it needs https to work, it’s because Google has bought it as a real domain name. Chrome switches to https and tries to find the domain on the internet, rather than locally. You could in theory bypass that by messing with your computers hosts file to redirect requests to .dev domains back to your machine but it’s simpler to just use something else.

Ive got a hunch that the Fritzbox is changing the URL because the DNS service on the router is not yet aware of the .dev domain being a real one, so it’s kind of getting stuck. I wonder if that issue persists if you set your computers DNS to use Googles rather then the router / isp DNS? If your not a fan of Google or have privacy concerns OpenDNS and Clourdflare also provide DNS services for free.

MAMP automatically inserts any domain you create as host into the hosts file, so no need to mess with this manually. But you are right that Chrome automatically redirect .dev domain to https, so using this should really be avoided.

I used to use .dev myself locally and Chrome (and Chrome based browsers) seemed to do it regardless of what was in the hosts file. I was able to view a .dev domain locally through BrowserSyncs built in proxy but that was patchy.

Maybe one of these articles can help

@ jimbobrjames
You’re hunge was right. The Fritzbox router has made some entries in the DNS network settings on my system. It is the IP of its configuration interface and a domain of “fritz.box”. I used to have there googles DNS servers but they are gone, after changing the router and the ISP.

1 Like

Interesting. Well, you can actually make those settings on your machine, rather then on the router. There is a guide here.

I’ve never heard of a router changing settings on a computer though, seems odd to me.

I wonder how that router did it, but it filled out these settings. Is was its IP, what looked like a MAC Adress and a name (fritz.box). I deleted the IP and the MAC Adress and put Googles 8-things back in and all is still fine. All MAMP and CodeKit connections work plus - I still have internet… !