How to disable KirbyTag rendering for a specific info field on Panel?

Hi,

I’m wondering if it’s possible to disable automatic KirbyTag rendering for a specific info field in the Panel.

Use Case: I created a custom KirbyTag to include icon files and extended the icon file blueprint to include an info field, from where you can copy the necessary tag into a writer field. The problem is, that info fields can render KirbyTags, so instead of displaying it, it automatically gets rendered. I tried adding it to the page model, but it gets rendered anyways. I tried adding it to a disabled text field instead of an info field, there it’s not rendered, but disabled text fields are styled in such a way, that you can not easily select it for copy.

Extra info: custom kirbytags with uuids would be my workaround, until this is implemented: Link to page/file in writer field (picker UI) · Kirby Feedback

Thanks!

Replacing left parens with ( should do the job.

Works perfectly, thanks!