Gulp/Kirby StarterKit (plus optional Docker support)

Hello there,
as some of you might remember, I released my Kirby boilerplate with Gulp integration a while ago on Github. I’ve been working on a K3 version recently, which is now fully operational:

For a full feature list, check out its README. Basically, all configuration is done inside config.js with many comments and links.

Besides local PHP/Webserver setups and LAMP solutions (MAMP, Virtualbox/Vagrant etc), I wanted to keep basic support for development with PHP’s built-in server (currently default via Gulp). At the same time, simply downloading it should also work.

Also, I prepared all necessary files (mostly index.php and documentation) to easily switch to the (somehow recommended) more secure setup (removing compatibility with Valet & PHP’s dev server).

Furthermore, I forked @rasteiner’s excellent Docker Compose repository for out-of-the-box StarterKit integration, which can be found here:

I 'm always happy to receive your input, thoughts and suggestions!



I waited for this, thx so much!
Not a docker person myself, but the rest is gold. But what about webp support? maybe also font optimising / subsetting stuff would be great

Now that Firefox supports WebP, that’s really an option. In my K2 version, I supported basic WebP generation, and for K2 itself there was a (pretty simple) plugin. Whenever I find the time, I’ll spin something up :wink:

Releasing v2.0.0-beta.2

  • Automatic font subsetting landed (achieved via glyphhanger by filamentgroup)
  • For Kirby’s css('@auto') option, just place .scss files - without leading underscore - in source/styles/templates and you are good to go!

Full (but very brief) changelog here.

I tried to install the package with this command

composer create-project s1syphos/gulp-kirby-starter-kit my-project

but it fails and I get the error

Could not find package s1syphos/gulp-kirby-starter-kit with stability stable.

what am I doing wrong?

solved with a composer.json in my folder

it looks like this

“require”: {
“repositories”: [
“type”: “vcs”,
“url”: “

then I run it in my folder

composer create-project

I’m changing something like the page title and it refresh the panel automatically. It is possible to deactivate the refresh in the panel? @S1SYPHOS

The latest commits include an automated critical CSS approach ootb, check the README for more information about it :wink: