Git kirby (untracked content)

Anybody know why my kirby directory (installed via git) would show untracked content when I run git status? I haven’t changed anything inside, just switched branches. Specifically, git says the toolkit directory is untracked.

Is it a fresh install? Which command(s) did you run to clone the repo? I ask because there’s git clone and git clone --recursive

Thanks Pedro. It was fresh initially–is that what you mean? I used the --recursive flag to download all submodules and their submodules. The site has been working fine until I switch between branches. It doesn’t track updates to my subrepos when I change branches and I have to continually run the following two commands.

git submodule foreach --recursive git checkout master
git submodule foreach --recursive git pull origin master

Weird thing, even after I run those, git still says the toolkit/ directory is untracked at the main project level.

As of Kirby 2.4.0, the toolkit/ folder has been moved to vendor/getkirby/toolkit/.

The repo doesn’t expect a toolkit/ folder, so it thinks that folder is an untracked modification to the main project.

You can safely delete the folder.


Sam you rock. Thanks man.

1 Like