Files not writable on server


I am having a problem when publishing a site to a server and attempting to access the /panel. The same site hosted on AWS (elastic beanstalk) allows access to the /panel without a problem.

I know this was covered in another topic but theirs was pushed from github and mine is not. I’ve been running locally from MAMP while building, and hosting tests on AWS, as mentioned, all without any trouble at all.

Where can I go/what can I do to make these files writable??

We are running PHP 5.4 on the server.

Do you have shell access to the server?

Check out this post to change permissions (and ownership if required)

It seems that I do, but I’m running into a few roadblocks I think. Thanks for providing that other thread… I’m trying to follow it accordingly…

I’m using Terminal on Mac OS, and in the root folder I ran the ls -la command which resulted:

drwxr-xr-x.  3 root root  4096 Jan  2  2014 .
drwxr-x--x. 24 root gabia 4096 Dec 27  2016 ..
drwxr-xr-x.  2 root root  4096 Jan  2  2014 mrtg

Trying to run the command to change right to all files/folders, requested [sudo] password for the user, and unfortunately I got this:

[username] is not in the sudoers file.

I don’t know what this means.

By the way, if its helpful at all, in my instance I’m moving my Kirby site from my localhost to the server by FTP.

Does this mean I actually don’t have access? What can I do?

That folder doesn’t look like your webroot?

Well, actually, it seems I don’t have access.

-bash: /bin/uname: Permission denied

Obviously, this is not a Kirby problem, so I’ll close this topic. Thanks for the other thread/resources!

Maybe contact the hosting provider. There must be some way to make these files writable. You should also be able to change permissions (but not user groups) if you right-click on the folder when it is open in your FTP client…

Oh! I see that now, I had no idea! So for example, in /accounts UNIX permissions should be 775?

755 should be sufficient, but that probably depends on the user group.

Sorry, because this is what I see when I change permissions, it changes to 777. Should I leave as is?

Well, try if it works with 777, not ideal, but…

Hmmm, now I get this, even after clearing cache/cookies:


Are you using any redirect anywhere? Like in this post: Too many redirects?

Or this one: Redirect error with multilanguage setting


No I’m not using any redirect anywhere and there is no password or login feature. I read through that thread, Too many redirects? but its not my case.

And I also have a language-specific file for every portion of the /site, as in the other instance you shared:

Here’s my config.php

c::set('languages', array(
    'code'    => 'kr',
    'name'    => '한국어',
	'default' => true,
    'locale'  => 'kr_KR',
    'url'     => '/',
    'code'    => 'en',
    'name'    => 'English',
    'locale'  => 'en_US',
    'url'     => '/en',

So I’m really perplexed. Again, the /panel was accessible on AWS hosting and through my localhost.

Hm :thinking: Does the error disappear if you undo the permission changes?

Yes, but then the same /panel/install error that I began with comes back.

I’m afraid I can’t really help you with this, then :cry: I suggest you contact your hosting provider, maybe they can help.