Favicon not showing up on child pages

Hi there,
The favicon in child pages is not showing up, because the path is different for those pages.
Is there a way to resolve this without creating a new template for these archive pages?

Showing up: https://sashaportis.com/cindy/starterkit-master-FINAL/the-celibate-machine
Not showing up: https://sashaportis.com/cindy/starterkit-master-FINAL/archive/graphica

ALSO, anyone have a tip on a good favicon generator that allows for transparent background rather than adding a default white bg to each version?

The path is wrong, should be/assets/....

Which one did you use?

I linked to the favicon in the head snippet, like so:

which works for all pages except the nested archived pages.

as i said… the slash is missing

Tried that:

now it's not showing up on any of the pages. Perhaps a separate template/head for the archive pages is in order since they're nested one level, unlike the rest of the pages?

You tried this?


More than one head.php won’t be necessary …

It’s because your website is in a subfolder.

Your favicons are here:

Using a relative URL with a slash before is the way to go, but then you’re pointing to:

Alternatively, you could use this to always get the real root of the website:
<?= $site->url() ?>/assets/favicon/favicon-16x16.png

1 Like



ah yes that worked thanks @cadars!