Fatal Error when moving from local to hosted space

I’m receiving the following error: “Fatal error: Call to undefined function load() in /home/rowlett/shandakenprojects.org/dev/kirby/bootstrap.php on line 10”

I am using Kirby CMS Bootstrap Starter Kit. http://www.getkirby-themes.com/themes/bootstrap-blog-starterkit so I checked line 10 in bootstrap.php which contains the following: “// load all core classes
load(include(DIR . DS . ‘classmap.php’));”

Then I ran an info.php to check version: PHP Version 5.6.29

The site works fine locally, so I contacted the hosting provider who said “It sounds like the site has a method being called that either doesn’t exist, or has a different name”

Any ideas of whats going on are greatly appreciated. Thank you, Ryan

Looks like the toolkit is missing. How did you deploy?

Hello and thank you for your reply,

Im not certain what you mean by deploy, but there is a folder called toolkit here: kirby > vendor > getkirby > toolkit

Is this what youre referring to?

Thanks again,

Yes, is there something in that folder or is it empty on the server?

With deploy, I mean if you transferred the files via FTP or if you used Git?

I used an FTP

The folder contains:


each of these folders seem to have all of the appropriate subfolders that ship with Kirby starterkit-master

Hm, I’d try to reupload the Kirby folder, maybe something got corrupted.

I replaced the entire kirby folder with a fresh one from .zip and it did change the error. Now Im getting this:

Fatal error: Class ‘Whoops\Run’ not found in /home/rowlett/shandakenprojects.org/dev/kirby/kirby/errorhandling.php on line 40

Maybe the upload is not complete yet?

Haha—I was doing it before you suggested it. Just in case, but its definitely completed.

Just on a side note, you should secure your server, all folders can be indexed…

Okay, I will. Thank you

I don’t know, something seems to be going wrong with your upload. Do you get any error messages when uploading?

Im gonna reupload the whole thing and see what we get

A lot of the files seem to have a file size of 0, so there must be something wrong

AHA!! Errors!!

  1. Upload v.php failed 425 Unable to build data connection: Connection refused.

  2. Interoperability failure 200 Type set to l.

Sounds like call the host again

The issue was that I was connecting with FTP rather than SFTP and hitting some limits during upload but now I am getting a new error:

Not Found

The requested URL /dev/project-b/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

This seems like more of a mainstream topic so I will search for it. Thank you for your help


I was actually unable to find a topic that had the same error. Any suggestions would be much appreciated.

Make sure that you uploaded the .htaccess file. You might have to set the RewriteBase in that .htaccess file to the subfolder.

Theres no .htaccess file anywhere on my machine despite having AppleShowAllFiles TRUE

I take it all back. That fixed everything. Thank YOU!