Failed to fetch on login page

My website worked well, but one day, it suddenly looks like a screenshot below, and I can’t log in at all. (If you access the panel, it will appear on the login screen.)

I recently linked the domain to the cloudflare.
I didn’t do anything else.
The reason why I connected the claudflare was to write https. (The front page works fine, but I can’t access the administrator page.)

I don’t know what caused this error…
Somebody help me.

The reason why this is happening is in those error methods: the fetch request to the API is going over http instead of https, therefore it is blocked.

See this issue: [3.7.0] Panel blank on cloudflare · Issue #4443 · getkirby/kirby · GitHub

What’s your Kirby version?

It’s Kirby version 3, but I don’t know exactly, because I can’t enter the administrator page. However, I installed it as a startkit in 2020.

I tried to install a new Kirby after receiving the answer, but I couldn’t install a new Kirby version because my hosting php version was 7.3. And the php version cannot be upgraded.

Is there any solution in this state?

You can find the version in the composer.json file inside the /kirby folder.

If your version still supports PHP 7.3, you must have a Kirby version prior to 3.6.0, because support for PHP 7.3 was dropped with that Kirby version.

If your hosting only supports outdated versions of PHP, I would consider changing your hosting provider. The only PHP versions that still receive security support are PHP 8.x., see PHP: Supported Versions

The issue reported on GitHub that I linked above refers to newer versions of Kirby though (3.6.x).

Try to set the url option in your config.php if you haven’t yet to see if this might solve your issue: url | Kirby CMS

My kirby version is this.

"require": {
        "php": ">=7.1.0",
        "getkirby/cms": "^3.0"

No, that is not your Kirby version, there should be a version key in that file

My version is “version”: “3.4.3”.
I’m sorry I told you wrong.

Have you tried to set the url in your config.php as I suggested above?

There shouldn’t be both http and https

Hm, not familiar with Cloudflare. Are you forcing https in your htaccess?