Editor & Builder plugin rendered content looks like JSON

Integration succeeded on the panel side, but now the content on the webpage of the site itself is rendered as JSON

Have you set the pretty option to false for the editor?

Not that I know of, where can I find that option? In the field.php file it’s true

I think its not documented yet:

  type: editor
  pretty: false

setting it to true or false in the text.yml didn’t make a difference

How do you output the content of the field?

I’m using the microsite template from the demokit, so maybe that snippet should be slightly different?

If the snippet uses kirbytext() instead of blocks() to render the content, then you have to adapt the code. kirbytext() doesn’t work for the editor.

I changed the kt() to blocks() but sadly no difference in rendering the content

Not even when you set pretty: false for the editor field?

No sadly doesn’t change




Hm, as far as I know it is supposed to work, but haven’t tested since the last update. Will try to look into this later if nobody else comes up with an answer in the meantime.

Ok, I tested this in the demokit and if I change

<?= $data->text()->kt() ?>


<?= $data->text()->blocks() ?>

in /site/snippets/blocks/text.php, the content of the text field is rendered correctly.

Thanks for the effort @texnixe , but at this point it still doesn’t work. I copied the microsite template/snippets/blueprints from the demokit and use it in a starterkit. Is there something else what could cause this problem? In the microsite, the builder is used but not together with the editor.
So maybe I should file a bug for the builder plugin?

I just realized that you turned both the heading and the text fields into editor fields. Does this make sense at all? And if so, have you made sure to use the blocks() method on both fields?

You’re right, the Heading doesn’t need to be an editor. I changed that but for the text field the results are sadly still the same.

Which version of the builder are you using?

Thanks, that was the solution! I downloaded the zip from the latest one and dropped it in the plugin folder after first removing the former one and installed the latest version of the builder plugin.
Which did the trick! I’m not aware of installing an older one then the latest, but probably I did

Thansk for your time and effort @texnixe

1 Like