Disable & Reset rate limit

I am using kirby as a headless cms and therefore I am doing a lot of requests to the API endpoint. Now I am receiving this error:

      status: 'error',
      message: 'Rate limit exceeded',
      code: 403,
      exception: 'Kirby\\Exception\\PermissionException',
      key: 'error.permission',
      file: '/kirby/src/Cms/Auth.php',
      line: 523,
      details: [],
      route: 'query'

As my application will not be available for the public (and of course to make developing easier) I would like to disable the rate limit check completely. I have not found anything in the documentation to disable rate limiting or how to reset it. Is there something I am missing? When I disable line 523 in /kirby/src/Cms/Auth.php it works, but of course thats not a good approach :slight_smile:

The rate limit refers to your password not validating, so there seems to be something wrong with your authentication.

You can change the number of allowed trials in the config: auth | Kirby CMS

1 Like