Disable positioning / sorting children pages

Hello everyone,

I’ve got an event overview blueprint (parent blueprint), every child is an event.

The blueprint of parent page part that show child looks like this:

type: pages
layout: table
label: Zeitfenster
text: "{{ page.date.toDate('%d.%m.%Y') }}"
template: event.page.entry
empty: Keine Zeitfenster vorhanden
sortBy: date desc
image: false
sortable: false
flip: true
columns:
 ...

Now the children page template (event.page.entry) has the option not to sort/position page. But when I change the status of children from parent blueprint page I still have an option to position it (“Bitte wählen Sie eine Position aus”):

Is there the way to disable it, or to use “num: zero” like the child templates?

The only technical difference between “listed” and “unlisted” statuses of pages is the presence of the sorting number. You could therefore allow only “draft” and “unlisted” for the event pages (instead of the current “draft” and “listed”).

1 Like

It might make sense to set sorting to something other than default sorting by number if you want to make the pages listed.

This is a good idea! In frontend it’s being already sorted by date.

@texnixe my ideal case would be to sort it automatically according to date field. It already happens in blueprint list view.

Then id set num to date?

1 Like

Please delete the thread, I’ve made pretty stupid mistake where to put “num:” value. Now everything works as intended. The error was behind the keyboard.:see_no_evil: