Disable Markdown in a textarea field

I’d like to disable markdown in my textarea field as it is doing some problems when typing “" in a text.
I’ve read some similar posts where you can add a component which filters out those "
” or prevent the text from getting italic.

But I don’t need markdown at all, so how can I simply disable it in a field? “markdown: false” seems not to work…


the italic line shows exactly what I want to prevent :sweat_smile:

Multiple solutions to your problem:

  1. Escape the * characters by typing \*
  2. Use ->kirbytags() instead of kirbytext() in the template
  3. Replace the * characters in a kirbytext:before hook
1 Like

Thanks, “kirbytags()” works for me but as soon as I paste text with stars in the text block in my panel, it will automatically create italic lines…

That’s impossible. I guess you don’t mean the textarea field but some other field? Maybe the writer field?

There’s an open issue for disabling this behavior for the writer field: Writer field: Option to disable markdown input · Issue #3138 · getkirby/kirby · GitHub

I am using a textarea field :slight_smile:

Is there a solution for the textarea?