Default Contact Form from Theme

Hi there.

I am using the very good Zero-Theme and I’m trying to get the contact form to work.

I changed the from mail adress and the to mail adress
to Mailadresses on the same server.

I checked the

I checked the
site/theme/templates/emails/email.php and email.html.php

But somehow I still get an “Form can not be sent” -error

Is there any settings, that I need to change on my server? I am using DomainFactory.

There is a php file in
Do I need to change anything there?

Thanks in advance, I’m pretty lost.

It might be that sendmail is not enabled on your server or you might have to add SMTP settings. I’d try to find information in the DomainFactory documentation or contact their support.

If you need theme specific support, please contact @mrfreedom, the theme developer.

Thanks for the quick response, I tried to Email the zero-Support, but no response so far.

There is a post in a forum suggesting the following:

“Ohne sonstige Angaben versendet PHPMailer weiterhin über sendmail, also den Webserver. Das isSMTP() ist da um eben zu sagen er soll direkt einen SMTP-Server und nicht sendmail nutzen.”

But where to add the isSMTP(). ?

In the php.ini ? Or in a php file in the theme?

You would have to set the smtp settings in your config, in the email configuration


So I put the email code in that file:


return [
'email' => [
'transport' => [
  'type' => 'smtp',
  'host' => '',
  'port' => 465,
  'security' => true,
  'auth' => true,
  'username' => '...',
  'password' => '...',


I don’t get an error code, I count that as a success. But the site is taking forever to load, like really, nothing is happening. The Chrome-Wheel is just spinning around.

Edit: Error code after 4 Minutes

1 Like

Hi, Thomas!

It seems that my email didn’t get to you. I answered you on Tuesday.
Are you sure your email is working correctly?

You don’t need to modify anything in the template files. Just add your email in Site Settings.
And, if your host doesn’t allow websites sending emails add Kirby SMTP options to config.php file.

You can also modify the email you are getting by changing code in site/theme/templates/emails/ files.

It means authentication started, but it failed.
Check SMTP parameters, have you added them corectly.

If you are unsure, you should ask your hosting provider what are the SMTP parameters for your account.

Try with 'security' => 'ssl'.

Thanks for your help.

'security' => 'ssl'


I tried different host names, too:

 'host' => '',

did not work.


 'host' => '',

did work.

Thanks. Problem solved!

1 Like

Of course, this is an example only, probably from the cookbook recipe. The correct settings for host, port, username, and password are depending upon your provider.

Yes! Even my provider offers two different options.