Blank website when viewing in the browsers


I moved a few of my websites to another computer, now I am getting a blank website. Can someone please help me.

Please provide more background.

  • What is your environment? Localhost or remote server? Apache or Nginx? If localhost, what is your dev setup (Mamp, Xampp, valet, other?)
  • What Kirby and PHP version?
  • Have you checked if the server meets Kirby’s requirement?

I am using the latest Mamp Localhost and Kirby 2.5.11.
Using PHP 7.2 and Apache.

Usually Kirby runs out of the box in a MAMP environment. Maybe you forgot to copy some files. Please enable debugging and check the server and PHP error logs.

This is what shows up in the php error log on my Mac and Win 10.

Thank you for helping me.

[23-Dec-2018 00:04:33 Europe/Berlin] PHP Warning: require(/Users/inxsnetwork/Dropbox/Website/Kirby_CMS/patara-kirby-and-html/patara-kirby/kirby/bootstrap.php): failed to open stream: No such file or directory in /Users/inxsnetwork/Dropbox/Website/Kirby_CMS/patara-kirby-and-html/patara-kirby/index.php on line 6

[23-Dec-2018 00:04:33 Europe/Berlin] PHP Fatal error: require(): Failed opening required ‘/Users/inxsnetwork/Dropbox/Website/Kirby_CMS/patara-kirby-and-html/patara-kirby/kirby/bootstrap.php’ (include_path=’.:/Applications/MAMP/bin/php/php7.1.22/lib/php’) in /Users/inxsnetwork/Dropbox/Website/Kirby_CMS/patara-kirby-and-html/patara-kirby/index.php on line 6

Does the bootstrap.php file exist in this place?

What is in your .htaccess?

Here are both the bootstrap.php and htaccess.

Thank you for your help. I will start with clean and latest version of kirby CMS.

# Kirby .htaccess

# rewrite rules
<IfModule mod_rewrite.c>

# enable awesome urls. i.e.:
RewriteEngine on

# make sure to set the RewriteBase correctly
# if you are running the site in a subfolder.
# Otherwise links or the entire site will break.
# If your homepage is
# Set the RewriteBase to:
# RewriteBase /mysite

# In some enviroments it's necessary to
# set the RewriteBase to:
# RewriteBase /

# block text files in the content folder from being accessed directly
RewriteRule ^content/(.*)\.(txt|md|mdown)$ index.php [L]

# block all files in the site folder from being accessed directly
# except for requests to plugin assets files
#RewriteRule ^assets/plugins/([a-zA-Z0-9\.\-_%=]+)/(.*)$ site/plugins/$1/assets/$2 [L,N]
#RewriteCond $1 !^plugins/[a-zA-Z0-9\.\-_%=]+/assets/.*
RewriteRule ^site/(.*) index.php [L]

# block direct access to kirby and the panel sources
RewriteRule ^(kirby|panel\/app|panel\/tests)/(.*) index.php [L]

# make panel links work
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^panel/(.*) panel/index.php [L]

# make site links work
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php [L]


# Additional recommended values
# Remove comments for those you want to use.
# AddDefaultCharset UTF-8
# php_flag short_open_tag on