API timeout on certain pages

After changing the URL of some pages I can no longer access them via the panel. The API response is “504 Gateway Time-out” after 1 minute of waiting. All the other pages work fine.

Does anyone have an idea how to debug this?

1 Like

Have you tried the usual stuff like logging out and clearing the browser cache?

How did you change the URLs, via the Panel or in the file system?

I fixed it by manually removing the .lock file from the pages. It seems like something went wrong while Kirby was renaming the folders.

Overall the panel is very weird. More often than not some parts of the panel don’t load because of different errors. That probably happened also while changing the URL of the pages I mentioned above. Could it be the read/write speed of the server?

Is that something you only experience since updating to 3.4.4? Or only on a particular server? Locally or remote? Only recently I kept running into issues with the built-in PHP server for some requests, maybe due to wrong ini settings. If you can’t find a solution, you might want to open an issue on GitHub just in case.

It’s hard to debug. I tried pretty much everything.
Maybe something is wrong with the server’s hard drive. I’ll let you know when I find a solution.

Something similar happened to me. I went on a locked article unlocked it and then tried to rename it and I got the gateway timeout. Every kind of php thing was frozen then. Even a simple index.php with an echo statement. I had to go to my providers backend and change the php version vom 7.4 to 7.3 and back to restart the php.

Have you experienced this more than once? Is the issue reproducible when you perform the same steps again?

Sorry to pull up an old issue but a client has had this issue a number of times now. They supposedly changed the URL of a page and it caused the same issue.

It’s weird because it’s not possible to consistently reproduce, but it’s something my client has had me fix a few times now.

I’m not sure why removing the lock would even make a difference but it fixes the problem for me too - but definitely not ideal given the client cannot do this independently.

They are using Kirby and PHP 8.0.10 and the logs just show a 504 error.

The question is if this is a Kirby bug or something setup related or both.

@waffl You are using a Kirby version that is not up to date. So I would first try if the issue persists with the current version.

@thguenther Have you ever experienced this again or were you able to debug this?

My client switched servers and it doesn’t happen anymore. I still have no idea what the issue was unfortunately.