500 error on new clean Kirby install

I just installed Kirby using cPanel’s Softalicious (yes, I’m a layz dude :stuck_out_tongue: ) and now I can’t get to the panel even though the other subpages function.

Install is on A2 Hosting, PHP 7.2.

Help? :slight_smile:


Kirby .htaccess

# rewrite rules
<IfModule mod_rewrite.c>

# enable awesome urls. i.e.:
# http://yourdomain.com/about-us/team
RewriteEngine on

# make sure to set the RewriteBase correctly
# if you are running the site in a subfolder.
# Otherwise links or the entire site will break.
# If your homepage is http://yourdomain.com/mysite
# Set the RewriteBase to:
# RewriteBase /mysite

# In some enviroments it's necessary to
# set the RewriteBase to:
RewriteBase /

# block text files in the content folder from being accessed directly
RewriteRule ^content/(.*)\.(txt|md|mdown)$ index.php [L]

# block all files in the site folder from being accessed directly
# except for requests to plugin assets files
#RewriteRule ^assets/plugins/([a-zA-Z0-9\.\-_%=]+)/(.*)$ site/plugins/$1/assets/$2 [L,N]
#RewriteCond $1 !^plugins/[a-zA-Z0-9\.\-_%=]+/assets/.*
RewriteRule ^site/(.*) index.php [L]

# block direct access to kirby and the panel sources
RewriteRule ^(kirby|panel\/app|panel\/tests)/(.*) index.php [L]

# make panel links work
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^panel/(.*) panel/index.php [L]

# make site links work
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php [L]


# Additional recommended values
# Remove comments for those you want to use.
# AddDefaultCharset UTF-8
# php_flag short_open_tag on

Double check the PHP settings for the domain in cPanel. It usually writes the desired version to the bottom of the .htaccess file - if you update kirby, you will likely loose this setting. The panel might not be working becuase the domain is actually using the system default which is usually something hideously old like PHP 5.4.

Verify its actually using 7.x and we can go from there. You may have to change the PHP version to something else and then back to 7.1 to have it write the setting to .htaccess.

Also have you enabled debugging - what error messages are you seeing, is it literally just a 500 on the panel URL?

Thank you. :slight_smile:

I double checked using a file containing

<?PHP phpinfo (); ?>

and it’s on PHP 7.2.11. I can link to that file if it is any help?

Just switched on debugging and it’s not showing any errors or should errors be in some log file on the server?

Yes, literally a 500 on the panel url.

Try commenting out this line

RewriteBase /
1 Like

Doesn’t help. :frowning:

Tried php 7.0 which doesn’t make any difference.

PHP info

If that’s any help…?

Hmm. Looks like the server has everything required installed.

Apache 2 with URL rewriting (mod_rewrite) or nginx
Since Kirby 2.5.11: PHP 5.6, before Kirby 2.5.11: PHP 5.4+. We recommend PHP 7.1+
PHP mbstring extension for proper UTF-8 support

Strange. Try checking the apache & php error logs to see if there are any clues in there.

You could try manually installing it - sometimes these automated installers make mistakes. Perhaps it mangled something. The fastest way is to upload the zip file for Kirby and unpack it on the server using the cPanel file manager.

1 Like

I’ll give that a go, thanks for your time :slight_smile:

Yes, that worked fine. :slight_smile:

I thought as much :slight_smile: