2.5.10 not reliably loading all CSS files

Ever since upgrading to 2.5.10 (when it was first released) my site does not reliably load all of its CSS files. Upon refresh, all of the styles load but not without this secondary, manual action. See below for example.

Is anyone else experiencing this with 2.5.10? My site’s cache is also empty when this is happening.



When you say when it was first released, how quick were you? 2.5.10 was pushed out twice on the day it was released due to an issue sneaking through. The zip file was updated a few hours later so If you re-download 2.5.10 now, you will the good version (the issue was to do with sorting more then 10 pages and not to do with CSS etc so I dont think its causing your issue)

How are you loading the CSS? I’m assuming with the helpers, but looks like your using some kind of cachebuster too. Does the issue persist if you do it the standard html way instead? For example:

<link rel="stylesheet" href="/path/to/yourstyle.css">

I just looked at your site, got the styles as intended (ie not like your screenshot) on the first visit. No reloading of the page or anything. I’m using the Opera browser. You mentioned the sites cache… what about your browsers cache - is that clean?

What happens if you use the starterkit? Do you still get trouble?

Can you please provide a little info about your server (Operating system, PHP version, NGINX or Apache, who is your web host).

Edit: perhaps the issue is down to render blocking. For a fairly simple design, your have some heavy dependencies. Multiple style sheets, multiple google fonts (with multiple weights on top), additionally the css and javascript could be combined and minified to reduce round trips. Enabling Gzip and setting up proper cache rules in .htaccess will help too. Additionally consider enabling HTTP2 if you can as this will further speed up data transfer from your server.

See a report here for guidance.

Ok, you definately got some weirdness going on. I had another look at your website and actually saw your screen shot issue once. I reloaded the page about 30 times and didn’t see it again. What was missing from your screen shot was some stuff lower down in the page - the debug message was actually getting displayed on the front end under your design. I have never seen that before. If you see that again, try taking another screen shot of that page. There are browsers extensions available for most browsers that will take a screenshot of the entire page, even the bits you cant currently see in the viewport. If we can get a good screenshot perhaps @texnixe can shed some light on what is going on.

On a side note, i did see an issue i have only seen once and for me it happened inside the panel for 2.5.10 and it went away on a page reload. basically im able to scroll way beyond the limits of the website by rolling the mousewheel. My screen is large enough to take your entire home page without causing any scroll (3440 x 1440 screen ). This should not be possible, but i managed to get a video of it.

I would double check your Kirby installation, and replace the panel and Kirby folders with a fresh download.

I did see that Whoops page underneath the rest of the page also, but when I reloaded the Page, it was gone again. Usually when we get the whoops page, you won’t see anything else, really weird.

Ah ha!!! Managed to hit the problem again and get screen shot (also getting the infinite scroll on it too)…

Oddly, if i do a view source on the page, the whoops stuff isn’t there. The HTML looks as intended. Bizarre.

@geofharries You could perhaps temporarily enable debugging on the live site. My hope is it will throw a complete whoops and give us a clue as to what isn’t happy. That will help the guys figure out if its something worry about or not.

i would like to think it might be just a mangled FTP transfer but I have seen that infinite scroll issue locally when no FTP happened.

Thanks for your help. I just turned on debugging https://gdharries.com

I think a few weeks after it was released, so not exactly right away but close enough, haha.

I consistently see the issue pop up in Safari, but not Firefox. As for the complexity of the resources being loaded, you’re right. I need to optimize that.


I just saw it again (in Safari), but had to reload the page a thousand times; Even though you said you enabled debug mode, so this error page shouldn’t come up at all. I’d suggest to make a clean install of Kirby and the Panel, clean up your code (if you need jQuery at all, update to a newer version).

If you have a PHP error log, check if there’s anything in it.

While I’m writing this, the page doesn’t work at all anymore, so I#m assuming you are currently making some changes.

I took the advice here and did a clean install. I think this may have fixed it, but only time will tell.

Your help and advice is much appreciated!