"www." is missing in rendered HTML

If I enter in a Kirbytext field “(link: https://www.example.net)” Kirby 3 renders, if I use e.g. <?= $page->text()->kirbytext() ?> in the template,
the following wrong HTML

<a href="https://www.example.net">example.net</a>

instead of the correct HTML

<a href="https://www.example.net">www.example.net</a>

Note that “www.” is missing in the visible text while “example.net” and “www.example.net” are two different (sub-) domains. This only appears, if the address starts with “www.”, not for other subdomains.

Is there an Kirby option to avoid such a change of the output.

(link: https://www.example.net text: www.example.net)

Thank you, but this is not what I need. The editors continuous not remember to this.

The default is from my point of view not very comfortable. To get, what the editor has typed ("(link: https://www.example.net)") , the rendered HTML should be the same and not a differing address.

I search for an option in the config files, that prohibited this truncation.

There is no option. But you can create a custom link tag that prevents this. The reason why this happens is in line 216 kirby/src/Html/Url.php

Its a bit of a non-issue to be honest. The href is the important part. Whilst, www is technically a subdomain, webservers imply www if its absent. Thats why it doesnt happen on other subdomains.

I agree with @jimbobrjames, if you absolutely need this, use one of the options suggested above.

Thank you very much, I have done

I have also added the in Kirby 3 missing Kirby 2 option “Opening the link in a new window”, which could be done under Kirby 2 by adding “ popup: yes” in the square brackets during input.
Above all, not all content files from Kirby 2 have to be changed for this reason.

Just for clarification:
The omission of “www.” already existed under Kirby 2.