Weird problem: "Bad group name: there."

I have a textarea field called text that I display in my template with <?= $page->text()->kirbytext() ?>

When I write

*there is some text*

in the field, I get

Bad group name: there.

thrown right after my <body>-tag and my html is all messed up,
for example a snippet that is being called in my header snippet is placed right after this message in the <body> instead of the <head>

When I place a space after the asterisk like

* there is some text*

the text is correctly rendered as a <ul> but the error message disappears.

**there is some text**


***there is some text***

also renders correctly as bold / bold-italic text.

It doesn’t matter what the first word after the asterisk is.
And when I just write plain text (no markdown) everything is fine.

What’s going on?

I can’t reproduce this in a Starterkit. What is your Kirby version? Which plugins do you have installed? What is your development environment? And can you also reproduce the issue in a fresh Starterkit?

Where is this error thrown? In the Panel? Or on the frontend? If on the frontend, there should be some stacktrace?

Also check your console for more information.

The error is thrown in the Spyc class, but to me, the context is not clear.

And what is actually stored in the content file when you save this string?


None, I just have a page-method that generates a svg.
But it isn’t called on the page the error happens, and deactivating it doesn’t prevent the error.

I’m on a Mac with Mamp 6.3 installed, running Apache server and PHP 7.4.12
coding in Visual Studio Code.

No. :thinking:
I changed the writer field into a textarea in album.yml and rendered the field in the album.php template with <?= $page->text()->kirbytext() ?>. All fine.

The error is thrown right into the html of the site.
I wrote test, set it in italic and this appears:

Bad group name: test.

weirdly enough, all the meta tags, that follow are called from a snippet within my header snippet and appear completly out of place in the body…

Nothing in there.

The error is thrown in the Spyc class, but to me, the context is not clear.

Title: Notes
Text: *test*

Have you tried to use a debugging tool like Xdebug to try and follow the code execution? If you want, send me a zipped version of your project and I’ll try to debug this for you.

I know of an issue with blueprint in the Spyc class, but I don’t know if there is the same issue with the content files. Maybe it will help you:

This issue is already solved, was a problem with a wrong field method.