I’d call them
imageElement() instead of
picset() because your plugin is adding stuff to the HTML element. And longer names are sometimes easier to understand and to remember and less likely to clash with other generic abbreviations.
On a side note: because working with responsive images is fairly complicated and best practice remains a moving target. I’ve also written my own snippets and kirbytags to convert images and use webp and different lazyloading techniques in the past.
I had considered your plugin a few times already to ease this pain, but despite its configurability, it never fully met my special requirements. But I am aware that it wasn’t meant as an universal solution and there are many cases, where it is just right and saving time. Therefore thanks and appreciation.