The form could not be saved . Exception: undefined (panel on FTP server)


From my panel (hosted on FTP server), When I try to fill fields of files without any template (so a default blueprint), when files are images, I get this error message: “The form could not be saved . Exception: undefined”. On the other hand, I can modify these informations if the file is not an image, like a PDF.
Locally, everything works fine. When I have pre-filled these fields locally and transfer to my deployed panel, when I click on one of these same fields (default files blueprint), the modification bar is displayed (which usually does not happen). And if I try to save these modifications : always the same error message.

I tried clearing: session folders, cache folder, content folder images, my browser cache, added "Header set Cache-Control “no-cache, private” and “php_value opcache.revalidate_freq 0” in . htaccess but it doesn’t change anything…

Below is the blueprints/files/default.yml blueprint which seems to be a problem:

title: Default File

  - width: 1/2

        type: fields

            label: "Légende"
            type: textarea
            size: medium

            label: Texte alternatif
            type: textarea

  - width: 1/2

        type: fields

            label: "Crédits"
            type: text
            width: 2/3

            label: Lien
            type: url

Thanks for your help, I don’t know what else to try…


Which Kirby version are you using?

When you enable debugging on the server, do you get anything more useful in the browser console?

Could you please also check your server error logs and/or php error logs.

I’m using kirby 3.6. No error logs on my cPanel.

Here is the specific error when enabling debuggin on my ftp server and try to modify my images with default template :
“slight_smile: POST 406”
“{code: 200, data: {…}, status: ‘ok’, type: ‘model’}”.

When I read the entire error object I see that template is on “null”, and “parent title: null” too.

Maybe it’s the problem, but I don’t understand why this is on null.

In the post you deleted, you had a different error message, was that unrelated?

BTW. Have you tried another browser?

After researching on google, I understood that these errors were related to Chrome and its extensions. I don’t get these async messages on other browsers.
I tried on Chrome, Firefox, Safari, my mobile… same message and problem to modify images infos…

Have you tried if you have the issue with a fresh Kirby Starterkit on your server?

Or you using any plugins, if yes, which ones? And also if yes, have you tried to disable them?