The file could not be uploaded - Managing videos in Kirby

I’m opening a topic here because I’m kind of lost.
I’m making a portfolio where my user can upload images using a blueprint with a file setup.
Everything is working fine with images but now my user would like to be able to upload videos.
I’ve a few options but I would like my user to be able to upload videos from their computer.

As soon as I upload a file, it shows me an error saying that “The file could not be uploaded”.
I know the other post about it but nothing seemed to work. I even changed the upload_max_filesize to 1800M in my PHP.ini.

What can I do to make things work?
Thanks a lot.

  • What does your files section setup in your blueprint look like?
  • How big are the videos?
  • And if you check your php error logs, is there any more information regarding the error?
  • Are you trying this locally or on a remote server? Apache or Nginx or other? If remote: dedicated server, VPS or shared hosting?

Hi Texnixe.
Here is my blueprint:

title: Project
    extension: jpg, png, mov, mp4

    width: 1/2
        type: fields
            type: text
            type: textarea
            label: Linked text
            type: pages
            multiple: false
            query:  site.children.children.listed.template("text")
            text: "{{ page.title }} || {{ page.texte.excerpt(180) }}"
    width: 1/2
        headline: Images
        type: files
        layout: cards
        size: huge
        text: "{{ file.title }}, {{ }}, {{ file.medium }}, {{ file.hauteur }}× {{file.largeur}}"
          back: "{{ file.color }}"

The video are not that big, less that 50MB.
Where can I check the php error logs?
I run locally but using the php -S localhost:8000 kirby/router.phpcommand.
I know this is not really recommended by Kirby. Should I try with Mamp?


This accept setting should go into a file blueprint that you assign to your files section, in a page blueprint it doesn’t do anything.

If you output phpinfo() in a template, you should see the path to the error_log file in the core section of the output.

Thanks for the reply, noted for the blueprint.
I added phpinfo()in my project.php template. I tried uploading a video through the panel but it didn’t gave me any error on the template page (in the core section) as I reloaded it.

Am I doing something wrong here?

No, what I meant is in the phpinfo output, you will find the path where your php error_logs are located. Then find those error logs in that location, and check if you can find any errors regarding the video upload there.

It’s probably just a problem php.ini settings like memory_limit, upload_max_filesize, post_max_size

The line error_log is showing : no value

Is the error log going to be located in my php installation folder /opt/homebrew/lib/php ?

I’ve also check the line error_reporting and it’s set to E_ALL.
Thanks a lot for the help,
I’m a true neophyte… Haha.

What are the settings for

  • max_execution_time
  • memory_limit
  • post_max_size
  • upload_max_filesize

according to this phpinfo()?

To get an error_log, you probably have to set it in your

The settings for:

max_execution_time : 30
memory_limit : 128M
post_max_size : 8M
upload_max_filesize : 1800M

I added the errog_log line in my php.ini, but the value of error_log is now php_errors.log which is not very helpful…

Setting upload_max_filesize without increasing post_max_size as well doesn’t make sense, try

post_max_size: 512M
upload_max_size: 128M

post_max_size should generally be larger than upload_max_size, or it will limit it.

Seems to be working just fine!