Textfield error


When I copy the word: spécialisée from Word into the textfield an saved I get the following error message

An nexpected error occurred

  • I tried to copy the word into sublime save as .txt closed sublime reopen the .txt with sublime
    and copied the word into the the panel textfield same error.

  • I tried to write the word into the panel textfieldthe same error.

  • I tried to close the browser reopen and write the word no problem

So the problem comes from Word but what can it be ?


title: default
pages: false

    label: Title in Navigation
    type: text

    label: Short Text
    type: markdown

    label: Full Text
    type: markdown

files: true
  sortable: true
      label: Caption
      type: text


Who knows, probably some hidden characters.

I’ve made the invisible visible

Bildschirmfoto vom 2017-08-07 15-41-35

same error

BTW: Does the error occur in the text field or the markdown field?

In the markdown field.

Have you tried with a native textarea field as well?

Yes, the same error.

tested on description()

title: Site
pages: default
    label: Title
    type:  text
    label: Author
    type:  text
    label: Description
    type:  textarea

est spécialisée dans le monde

I can’t reproduce that. I copied those words into a word document, saved, copied from Word into a Kirby 2.5.4 textarea field: no error. At least not on my Mac and on localhost.

–hmh, now I tested on an other server (hoster) it works maybe is a problem with the server. But what can I ask the hoster ?

Do you get any errors in console when this happens? Are the error logs on the server a bit more verbose as regards a possible reason for this issue?

Yes, the console output.

panel.min.js:5 [Violation] 'load' handler took 2357ms
edit 510 (Not Extended)

send @ panel.min.js?v=2.5.4:5
ajax @ panel.min.js?v=2.5.4:5
K.(anonymous function) @ panel.min.js?v=2.5.4:5
(anonymous) @ panel.min.js?v=2.5.4:7
dispatch @ panel.min.js?v=2.5.4:4
g.handle @ panel.min.js?v=2.5.4:4

Hm, that doesn’t tell me anything, apart from the fact that some load event handling took too long.

Is the mb_string extension present and enabled?

I think yes

phpinfo() output

Configure Command '--enable-mbstring'

very strange is

the word spécialisée -> error
the word spéeialisée -> no error

is the word a trigger point ?

I don’t think so, as I said, I can’t reproduce this and if it was a trigger, it wouldn’t work anywhere, would it?


I think I’ve found out why the error message appears

server .log

[Thu Aug 10 22:21:20 2017] [error] [client] ModSecurity: Access denied with code 510 (phase 2). Pattern match "[-_ ]?(?:adipex|suboxone|pseudovent|topamax|trazodone|prevacid|zyrtec|xenical|toprol|zoloft|synthroid|valtrex|wellbutrin|valium|protonix|vytorin|ritalin|zocor|seroquel|ultracet|plavix|voltaren|zyprexa|xanax|vicodin|penicillin|tramadol|provigil|predniso ..." at ARGS:short_text. [file "/usr/local/apache2/conf/mod_security2/asl_rules/30_asl_antispam.conf"] [line "248"] [id "300061"] [rev "25"] [msg "Atomicorp.com WAF AntiSpam Rules: Possible Spam or Restricted content: Pharmacy and/or Drug content detected"] [data "cialis"] [severity "CRITICAL"]

[data “cialis”] match spécialisée

Thank you @texnixe for your patience

Absolutely crazy. But what I don’t understand is why it only happened when pasting from Word, and not when typing it directly into the textarea field…

maybe I wrote the word wrong,

spécialisée -> spamfilter match
spécialiseé -> no error

so it’s nothing to do with copy from word it’s
o n l y the word

Hm, looks like both words have cialis in them :thinking:. But anyway, such a global spam filter is a bit weird. May I asked what hosting service you are using?

maybe split é cialis é