Template Pages Not Found


#21

These files are auto-generated by Kirby. If they are not created, there’s definitely something going wrong. Either the folder not writable (but I think Kirby detects that), or not enough memory/execution time for the script.

However, that still doesn’t explain why the subpages are not available.


#22

I loaded it on Mamp with PHP 7.1.16 and it’s working fine. It must just be an Apache/CentOs issue. Thanks for the help.

My live site is Centos as well so hopefully, it will roll out fine when the time comes.


#23

I got the same problems on a debian apache2 setup and also on my macos, which has apache2 and php7.2 installed using brew. Currently i dont get kirby3 running at all.


#24

I can confirm that issue on a vmware based Ubuntu 18.10 SMP 64 Bit / PHP 7.2.10-0ubuntu0.18.04.1 (cli) (built: Sep 13 2018 13:45:02) ( NTS ). Alle the mentioned extensions are installed (mbstring, curl, ctype extension, gdlib)

I do a fresh
git clone https://github.com/getkirby/starterkit.git kirby30,
start the built in PHP server (php -S localhost:8000) an will see not a single image in frontend - only black boxes - and no image in panel.

PHP outputs nothing helpully, only 404 like
127.0.0.1:58004 [404]: /media/pages/photography/animals/3779077927-1547930887/peter-fox-800x1000-q90.jpg - No such file or directory

In panel I get a JSON.parse: unexpected character at line 1 column 1 of the JSON data when clicking down the image placeholders. Maybe this helps.


#25

@rainerth If you use the built-in server, you have to call it with the router:

php -S localhost:8000 kirby/router.php

We do not recommend using the built-in server anymore.


Kirby site not rendering in localhost
#26

This makes the difference: my issues are solved. I have my images back. You saved my Saturday evening :slight_smile:

1000 thanks!