Subpage not working after Digital Ocean Deployment

look what happens if i access

That shouldn’t happen you have to prevent directory access

Have you tried to edit one of those subpages via the Panel? Can you save an edited page?

Have you checked the permissions of those subpages? They were created outside the Panel, it seems.

If all else fails, delete those icon folders and try to recreate the subpages from the Panel.

I can edit it, yes.

Again, is there any other stuff on the server? Any other .htaccess files around? Are you using any plugins?

Fresh new droplet, no other stuff on the server. Only one .htaccess

i have some plugins

What system are you using locally that it works on? I did notice that the URL has an upper case letter in it. Ive had issues on linux servers with mixing case (becuase linux is case senstive.) if your links are pointing to /essentials/ and your page is actually /Essentials you will see a 404. I sometimes accidnetly enter tags into a tag field with a captilized tag which ends up in the URL. That can cause issues with some hosting. Try making sure everything is lower case.

Who are you hosting with? Fortrabbit works great with kirby. You could try the $5 plan just to see it working. (I think they actually free trial so you might not have to pay anything)

1 Like

It doesn‘t work with lower case links/slugs either

I will give it a go and get back to you with the results.

Fortrabbit is WOW. in 5 minutes i was live. Deployed with git. Nice. Thank you so much for the support @texnixe and @jimbobrjames. Guys avoid DO if you want a simple fast solution. To much DevOPS.

Texnixe you are amazing. Serious.

Thanks for the praise.

I’ve seen other posts here in the past that recommended DO or DO in combination with some other tools.

But hey, if there are better options, then go for them. They seem to be helpful as well, from what I heard.

@Oliver_Stone Glad you got it going. I only reccommend things I have actually used. Ive seen postive posts about Digitial Ocean also, but never personally used it. I can also reccommend Krystal if you need more traditional style hosting (I have a VPS with them).

Guys avoid DO if you want a simple fast solution. To much DevOPS.

Well DO was born with devs in mind are are definitely not the solution if you’re looking for something that requires low devops.

I’m currently using 5 droplets on DO and had no issues so far (and I’m running kirby on all of them).

But if you’re looking for a fast and easy solution to go online, DO (and Linode and Vultr and all the other Cloud providers ) are not the solution.

Fortrabbit or Uberspace are probably a better solution.

@manuelmoreale You are right. But if you have any idea why we didn’t find a solution for the issue above, come forward, please?

Is this maybe some kind of Javascript coding issue and you try the site locally with a different browser than after deploying it? I see this in the console and a different browser may interpret it different:


Absolutely no idea, I’m useless when it comes to server configuration which is why I manage mine with a 3rd party service :blush:


I don’t think so, because the site works now on the new hosting

I think was something with the user permisions on the apache.conf. All clues for me pointed to this.
Js dosn’t interfeer with backend. I was manipulating the dom with it.

I had an absolutely same problem, so here’s the solution if anyone else comes through googling it, hth: The problem simply disappeared when i renamed the directory from “icons” to something else.

I would like to know what is the problem with the specific directory name (icons) but I’ll leave it for some less busy days, right now I’m happy it’s solved.