SSL option causes Email error

Hi guys,

i realized that my SSL Certificate (apparently it is “just” the code


in the config.php file)

causes an error at sending Emails via any contactform. The Error message is:

Fatal error: Uncaught Error: Invalid reply address in /www/htdocs/(mein geheimes Verzeichnis)/kirby/toolkit/lib/email.php:64 Stack trace: #0 /www/htdocs/(mein geheimes Verzeichnis)/kirby/toolkit/lib/email.php(119): Email->validate() #1 /www/htdocs/(mein geheimes Verzeichnis)/site/controllers/kontakt.php(50): Email->send() #2 /www/htdocs/(mein geheimes Verzeichnis)/kirby/kirby.php(525): Kirby->{closure}(Object(Site), Object(Children), Object(Page), Array) #3 /www/htdocs/(mein geheimes Verzeichnis)/kirby/kirby.php(699): Kirby->controller(Object(Page), Array) #4 /www/htdocs/(mein geheimes Verzeichnis)/kirby/kirby.php(680): Kirby->template(Object(Page), Array) #5 /www/htdocs/(mein geheimes Verzeichnis)/kirby/kirby.php(781): Kirby->render(Object(Page)) #6 /www/htdocs/(mein geheimes Verzeichnis)/index.php(16): Kirby->launch() #7 {main} thrown in /www/htdocs/(mein geheimes Verzeichnis)/kirby/toolkit/lib/email.php on line 64

Why is that and do you know what to do? Thanks in advance!


The ssl option will only redirect HTTP traffic to HTTPS traffic, not actually enable HTTPS, so it can’t really be your certificate. The option itself is also not related to the email class.

But: It could be the way you have setup your contact form that breaks when using HTTPS or because of the redirection.
Could you please post the template code of the form and the code in your controller that receives the form data and sends the email? Maybe there’s something else wrong there.