Setup VPS with Kirby

I’m setting up a Kirby site for the first time. I have the local environment working great, but I’m having a hard time getting everything working smoothly on my DigitalOcean VPS.

I’m trying to get my URL’s to appear as clean as they do in my local environment (eg. /page/sub-page/sub-sub-page) when currently sub-pages are appearing a with an /index.php before the /sub-page Also, I don’t have access to the panel page, not sure why.

The server is running Ubuntu LAMP on 14.04.

My files are at var/www/html

My test site is ** REMOVED LINK, PROBLEM SOLVED **

Any help would be appreciated.

Please see Kirby .htaccess on VPS. You might also need to enable mod_rewrite first.

I just tried that approach, and something changes my URL’s to be prettier. But I’m now getting a redirect loop on the panel. ** REMOVED LINK, PROBLEM SOLVED **

this is my .htaccess file

<IfModule mod_rewrite.c>

  RewriteEngine on

  RewriteBase /

  RewriteRule ^content/(.*)\.(txt|md|mdown)$ index.php [L]

  RewriteRule ^site/(.*) index.php [L]

  RewriteRule ^kirby/(.*) index.php [L]

  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^panel/(.*) panel/index.php [L]

  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.*) index.php [L]


AddDefaultCharset UTF-8

php_flag short_open_tag on

Have you tried with uncommenting the RewriteBase?

#RewriteBase /

You could also try to set your domain in your config.php


Hey, thanks for taking the time to respond, I tried your suggestion, but it didn’t work. :confused: Do you have any other ideas maybe?

You could put the .htaccess vontents into your Virtual host configuration as explained in the thread @lukasbestle posted above. I added an example there yesterday.

Hey @johnchourajr, did you manage to fix the redirect loop at /panel? I’m having the same issue here and it’s got me stumped.

I just wiped the VPS clean, did a clean install of Kirby. It did the trick.

I’ve actually done this too with no luck. Out of interest, were you using the starterkit?