Search Plugin / Nesting level too deep

Since a few days I’ve got the error „Nesting level too deep - recursive dependency“ from the search plugin (http://getkirby.com/blog/search). Is there a possibility to limit the search results or can I chance some php settings zu solve this problem temporarily until we switch to the new version of kirby?