Problems (bugs?) with multilang setup using external URLs

Hey guys,

Having some problems with a multilanguage setup when a language uses the external URL option in the translation config:

  1. The site is accessible through both and (external URL). Duplicate content is generally bad for SEO, so I’d like to avoid that if possible.

  2. The site is loading fine on, but there is a weird bug happening on the external domain where it is displaying pages that have been deleted in the panel (cache and sessions have been cleared as well) and not finding images.

Any ideas, insight, and advice are very much appreciated, thanks :slight_smile:

Do you have the same problem with a fresh Starterkit?

Not too sure what the problem was, but I deleted a few older pages that were not being used anymore, which solved most of the problem.

I have one issue left which is that a few subpages are being displayed on the frontend, but I deleted them in the panel, and they are also removed from the content folder. I have cleared my cache, sessions, and media folder. This only happens to the live version of the site, but I can not replicate this issue on localhost oddly enough. Any idea what would be causing this bug?

Maybe some sort of aggressive server-side caching?

That’s what I thought too, my server was using Varnish, but I disabled it for the time being. However, the problem is persisting.

Maybe you have to clear that cache in addition to just disabling it?

I tried purging it as well; customer support also has no idea what is causing the issue. Kind of an obscure problem, but if anyone uses Cloudways and has run into this issue or any others, I’d love to know how you solved it. :slight_smile:

In case anyone runs into this issue, I discovered the problem. The issue was Cloudways’s Git deployment tool. It does not delete any files when pushing with Git; instead, only duplicates are created.