Prevent custom block from opening overlay on create

I’ve created a custom block that overrides the default text block. It’s essentially a no-build file structure copy-pasted from the default single file component.

I noticed that adding a block of this new type in the blocks field immediately opens the block drawer – as opposed to the behavior of the default text block, which initially remains in its WYSIWYG state until you click on the “edit” icon.

Do you have any idea what might cause this behavior and how I can disable it?

You have to set

wysiwyg: true

in the block blueprint

1 Like

that was easy… thanks! :~)

I have a block that doesn’t have any fields (it is some kind of placeholder block that will render another page). Is it possible to completely disable the drawer as there are no fields to edit? So basically remove the small edit icon on the block preview.

@arnoson It’s already on the wish list and you might want to upvote this feature:

Great, thank you @texnixe!