Panel blank, www-Subomain, IONOS Hosting

I run a Kirby 3.6.2 (PHP 8.0) in a IONOS webspace. Both Domain and www-Subomain point to the Kirby folder.

With https://domain.tld everything works fine.

With https://www.domain.tld I get cross-origin errors, which is understandable since assets load from https://domain.tld.

So, when I add ‘url’ => ‘https://www.domain.tld’ to the confiq.php the website works fine again under https://www.domain.tld.

But the panel throws an error:

“Uncaught (in promise) DOMException: The operation is insecure.” for index.js and vendor.js.

The .htaccess is the Kirby standard from the plain kit + RewriteBase /

I tried to redirect the https://domain.tld to https://www.domain.tld in the domain settings but it didn’t help.

Any ideas? Thanks!

Could you try with It seems to me that URL detection isn’t working properly and we made a couple fixes with that release that could help.

Works! Thanks, Bastian! :beers:

1 Like

I’m running into the same problem with IONOS. Just updated to Kirby 3.6.5 because I remembered reading about URL detection problems in the release notes but it didn’t fix it for me. I redirect the non-www url to the www url. The the non-www domain gets detected leading to the noted cross-origin errors.

Edit: the hardcoded www-URL in config.php helped. The domain specific config without the www didn’t work. Note that IONOS needs the RewriteBase / turned on.

Edit-2: the URL-list solves it the best for now since I can have both my local development and the live url in there and it picks the correct one.

1 Like

For me it’s not working… and both have url set to, assets still want to be loaded from

RewriteBase is turned on and I’m on Kirby 3.6.6

Any ideas?


Ok, wenn I add the url parameter with www to the general config.php it works on the remote server… assets are now loaded from

BUT on localhost it STILL wants to load the assets from even with config.localhost.php url set to http://localhost

Something’s not right here: It seems like the url setting in the domain specific configs is not considered…?! I tried setting url in to and it didn’t change anything.