Pages not showing in panel

Hi there,

I currently upgrading an old kirby 2 project to kirby 3, while following guide to updating to Kirby 3. However, I ran into a problem while trying to display the pages. I know that by default, adding pages etc. is disabled so I tried enabling this within the .yml file.

This is the head of my site.yml:

title: Site
deletable: false
pages: true

# So I tend to use subpages, but I am unsure of how this goes into practice within site.yml
  - title: Landing
    uid: landing
    template: landing
    num: 1

# This I got from the starterkit
  type: pages
  create: default
    - about
    - banner
    - contact
    - default
    - error

# These are fields that have been migrated from my Kirby 2 project
  . . .

I am unsure whether I am doing something fundamentally wrong or just missing something.

Thanks for your help in advance!
Kind regards,

Is that a multi-language site?

These options do not exist, but they shouldn’t be responsible for the error.

The subpage_builder doesn’t exist anymore in Kirby 2 and has to be replaced with a plugin (I assume you have seen that in the guide?).

Yeah I was fiddling around a bit, oops… :grimacing:

It is indeed a multi-language site, with existing contents. As shown in guide I upgraded this. Also, I indeed saw in the guide that a hook needed to be added for the subpage builder.

I did fix the t.language error. It seems that there was something wrong with my initial save. After removing the modal in the html and clicking save button (which was shown below the overlay but disappeared as I clicked on the modal).

But still, I don’t get anything to show, unfortunately.

What content filenames do you use?

Both :confused:

Ok, the blueprint setup is missing the sections keyword. I think you should check out the Starterkit’s site.yml.

Title: site

  pages: # a pages section which lists pages with the given templates/blueprint
    create: default
      - about
      # etc.
  fields: # a fields section
    type: fields # the type is optional if the section is called fields, but you can only have one section with that name, if you need more, you have to give them other names and add the type.
        label: text

That’s still basic, you probably want to use columns for a more structured layout.

Argh, can’t believe I missed that. It at least shows the error page’s content now (and the option to add a page).

It still doesn’t seem to detect the other pages’ templates (and content subsequently), though.
I put my old kirby blueprints in /site/blueprints/pages/. Lets take a look at about.yml for example:

title: About
deletable: false
  - title: About Subpage
    uid: about_sub
    template: about_sub
    num: 1
files: true
      label: Page Info
      type: headline
      label: Title
      type:  text
      label: Menu
      type:  checkbox
      label: Website Title
      type:  text
      label: Superhero Image
      type: select
      options: files
      required: true

Any thoughts on what could be wrong?
Thanks in advance!

Hm, the section should actually show all pages with the given templates. Remove the templates option from the pages section for a moment to see what happens.

Your about.yml has an invalid field, a checkbox field does not exist in Kirby 3.

This does the job, very nice, but why? It don’t see why the filter would be incorrect?

Could you please post your content folder structure in a way that files are visible as well?

about.yml has another issue.

  fields: # the key for the section
    fields: # and the key for the fields

And again:

files: true


deletable: false

are superfluous, they don’t hurt but don’t exist as options.

Yeah I figured this out a second later but it didn’t make any difference, somehow.

Anyway, here is my folder+file structure:


Edit… It is quite obvious what the problem is. Somehow my content text files were renamed during the upgrade. After changing the to it showed up immediately.
Yet I still cannot add it as a new page with this template in the site settings :thinking:

Yes you are very right on this (although those files belong to the parent folder, “onze-kracht”).
To illustrate more of my structure:

Another structure picture:

So yeah, the page does show up as a page in the panel but when I click the “Add” to add a page I cannot choose the template.

Ok, last post was nonsense. So the page still doesn’t show up? And there are no other random files lying around?

Make sure to fix those other text files in all other pages as well.