oEmbed breaks on server, works on localhost

Lovely greetings!

Many thanks for taking the time out to read this :slight_smile: I went through the forum / oEmbed’s github, tried everything I thought might have gone wrong but couldn’t find anything that would be helpful, hence this post in desperation!

So here’s where I’m at.

-oEmbed and Kirby work perfect on localhost (MAMP on Mac OS X 10.10)
-Uploaded site to shared hosting server
-Kirby is live and kicking (You can see here dhairyadand.com)
-All pages that use oEmbed for videos, break. Specifically they parse till

<div class="text">

after which the page doesn’t show anything. I have the oEmbed tag as the first thing in

Examples: http://dhairyadand.com/works/supershoes http://dhairyadand.com/works/obake
Parsed source files: view-source:http://dhairyadand.com/works/supershoes view-source:http://dhairyadand.com/works/obake

This is what I tried-
-Reinstalled Kirby -> Kirby works.
-Deleted oEmbed from assets+plugin+thumb+cache
-Downloaded latest oEmbed from github - distantnative/oembed
-Installed following all the directions -> Added css, js and jquery to the header.php and copied to the assets and plugins folder
-Changed permissions on those two folders to 755

Can’t think of anything else!

My shared hosting server runs Apache 2.4.x +PHP 5.4.x if that helps.

Using oEmbed to have responsive embedded videos, the other solutions didn’t seem to work.

Much thanks again for reading all through till here!

Would appreciate any help, pointers, hints!


It says in the readme that it requires PHP 5.5+, don’t know if there’s been an update to change that requirement

1 Like

Much much thanks @texnixe!

You’re right! My localhost runs PHP 5.6.x, I think the problem might just be my shared hosting provider running PHP 5.4.x. I think it’s time I move to a VPS.

Such a wonderful Kirby community!

Lovely greetings from Seattle